cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Duplicate assets (Servers)

kjstech
Engaged Sweeper III
We have some servers that are listed as assets multiple times. For example I would have a server listed and fully scanned, but then it's listed again.. the only difference is the ESXi server its running on is listed as well.

Any way to prevent or introduce logic in the scanner to recognize these are the same thing a merge all relevant information into a single device record?
4 REPLIES 4

nnewton
Engaged Sweeper III
I've got similar issues with VMWare SRM standby machines being detected as duplicates:

2020-07-24 08:11 Renamed DOMAIN\MACHINE\1 to 421258c4-1a11-b14c-6d41-be20809429b5
2020-07-16 11:31 Renamed DOMAIN\MACHINE\1 to 421258c4-1a11-b14c-6d41-be20809429b5
2020-06-26 12:03 Renamed 421258c4-1a11-b14c-6d41-be20809429b5 to DOMAIN\MACHINE\1
2020-06-26 08:19 Renamed DOMAIN\MACHINE\1 to 421258c4-1a11-b14c-6d41-be20809429b5
2020-06-18 22:02 Renamed 00:50:56:89:0E:E1 to DOMAIN\MACHINE\1
2020-06-18 10:58 Renamed 421258c4-1a11-b14c-6d41-be20809429b5 to DOMAIN\MACHINE\1
2020-06-18 10:58 Renamed DOMAIN\MACHINE\1 to 421258c4-1a11-b14c-6d41-be20809429b5
2020-06-15 12:06 Renamed 421258c4-1a11-b14c-6d41-be20809429b5 to DOMAIN\MACHINE\1

After going back and forth with support and them not finding a solution (they don't have an SRM test environment), I just created a new status of "SRM Standby" and assigned one of each of the duplicates to this status. You have to do this with SQL as LANSweeper won't allow the duplicate asset name.

I found that the older record (first seen date) is the one with all the renames in the comments tab and the one you want to change the status of.

This effectively makes that asset inactive and as long as you don't manually re-scan one of the assets with the changed status, it appears to work.

You still have duplicate assets, and they still count towards your license, which is particularly annoying as this is an issue with the LANSweeper software yet the customers are paying financially for the workaround. But we import the LANSweeper data into our CMDB and this permits us to filter the incoming records.

Hopefully, when LANSweeper fixes this issue we can change the status back and the records will merge properly.

nbjeter3
Engaged Sweeper
Yeah, I'd love to know how that works out for you with support. I've had similar issues for a long time now. It happens with VM's non-stop because the Host machines have virtual adapters and those Virtual adapters have their own MAC addresses. I was originally having the issue where they would create a new asset, and mark the old one as inactive. Nowadays it still happens, but only randomly. Suddenly one day after several weeks of running just fine, 80+ computers will show up on my "Computers: New computer found in the last 24hrs." report. Now though it's no longer just VM's. It's happening to Thin Clients as well. I've been working with support over a month now on the issue and still no results.

kjstech
Engaged Sweeper III
Ok thanks for the article. I may raise an issue with support.

Looking at one of our VM's right now.

One record has the unique key beginning with 423f85fd-, and the other record has domain\COMPUTERNAME\1. All of the other fields are identical.

FrankSc
Lansweeper Tech Support
Lansweeper Tech Support
Hello,

Lansweeper has an internal logic to merge devices if they have the same unique identifier, for Windows computers this idnetifier is <NetBIOS domain or workgroup name>\<NetBIOS computer name>\1 as explained in the following KB article:
  • https://www.lansweeper.com/knowledgebase/how-lansweeper-uniquely-identifies-assets

If this article would not provide any clarification, the issue you are facing could be something specific. The best thing would be to send a mail to support@lansweeper.com adding screenshots of the duplicate assets you are seeing. Include also the version of Lansweeper you are currently running.