cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Getting scanning access denied error

Companyuser
Engaged Sweeper II

Hi Team,

My Lansweeper configuration is old and working fine as well. But recently added systems shows scanning access denied error. Not all machines in the asset list of Lansweeper have this error. Its only for few systems. I checked the access of the scanning username on the local machine as well. Everything is in place but still getting WMI access error when running testconnection on Lansweeper server for the culprit machine. testconnection works completely fine for other machine in the Lansweeper.

Suggest what could be the possible reason for the same. There are lot of similar issues reported on your portal but none of those steps worked for me.All my settings are in place.

4 REPLIES 4

LSEngineer2007
Engaged Sweeper II

If you have certainly verified that the scanning account has the proper access and the scanning credentials are associated to the scanning type (IP range or Windows for example).  You could try running these 2 commands directly on the computer.  Make sure the account you are using to run the commands has local administrator rights.   Reboot and try to scan again.

  • Winmgmt.exe /standalonehost
  • Winmgmt.exe /resetrepository

 

Keith

Even after running this command it is still the same.

RichieRich
Lansweeper Employee
Lansweeper Employee

Hey Companyuser - Thanks for using Lansweeper !

Not sure what steps you have tried so far but it sounds suspiciously like the MS DCOM hardening issue outlined in the Quick Tech Solutions part of the Knowledge Center in the Community -  https://community.lansweeper.com/t5/quick-tech-solutions/suddenly-seeing-access-denied-scanning-erro... - is this something  you've addressed already ?

That laptop does not have the KB updates as mentioned there 

  • KB5014697 for Windows 11
  • KB5014699 for Windows 10

So should I still update my server with KB- as mentioned on that site ?

  • KB5014738
  • KB5014808