cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

we have upgraded our server to the latest version (9.5.0.4)

Boudjema
Engaged Sweeper II
Today we have upgraded our server to the latest version (9.5.0.4).
After that, Lansweeper seems to be fine but we cannot push package anymore. Each time that we try, we have the following message:
“Preliminary checks failed. Task Registering Error. The current version of the native library (1.4) does not support the original or minimum version of the ".NET Framework NGEN v4.0.30319" task (1.6/1.6). This is likely due to attempting to read the remote tasks of a newer version of Windows from a down-level client. Credential: (FFF\administrateur). ShareCredential: (fmsf-MP007\Lansweeper).”

We have tried to install different packages to at least 4 computers without success. We also tried with different agents accounts.

NB: During the upgrade process, we have also installed the latest paches for the windows server.
6 REPLIES 6

Boudjema
Engaged Sweeper II
I also just got a solution from LS support and I confirm that it works again

Thank you very much for your answers

coffee2000
Engaged Sweeper
That worked, thanks!

ThKl
Engaged Sweeper II
Support just sent me a workaround:

• On your Lansweeper scanning server, open CMD as admin
o Do this on all scanning servers if you have multiple.
• Run the following command: (make sure the path is correct)
"c:\Program Files (x86)\Lansweeper\Tools\ConfigEditor.exe" /showfeaturetoggles
• In the featureToggles section of ConfigEditor, click Add
o Input Key: DeploymentsV2
o Input Value: 0
• Click save configs and restart service

ThKl
Engaged Sweeper II
+1 Same Issue. Server 2016 Clients Win 10. Hasn't been an issue before the update.

coffee2000
Engaged Sweeper
Same issue here - after upgrading from 9.2 to 9.5.

Only saw this on the internet, maybe Lansweeper uses this software to create the deployments:
https://github.com/dahall/TaskScheduler/issues/47

My Lansweeper server is 2012R2, the clients are Windows 10, but this always worked.

Boudjema
Engaged Sweeper II
Boudjema wrote:
Today we have upgraded our server to the latest version (9.5.0.4).
After that, Lansweeper seems to be fine but we cannot push package anymore. Each time that we try, we have the following message:
“Preliminary checks failed. Task Registering Error. The current version of the native library (1.4) does not support the original or minimum version of the ".NET Framework NGEN v4.0.30319" task (1.6/1.6). This is likely due to attempting to read the remote tasks of a newer version of Windows from a down-level client. Credential: (FFF\administrateur). ShareCredential: (fmsf-MP007\Lansweeper).”

We have tried to install different packages to at least 4 computers without success. We also tried with different agents accounts.

NB: During the upgrade process, we have also installed the latest paches for the windows server.



And I just updated the framework to 4.8 but I still have the same problem.
I am the only one to have this problem with the new version of LS.
I have sent an email to LS support on Friday but still no answer
Thank you for your help