Showing results for 
Show  only  | Search instead for 
Did you mean: 
Engaged Sweeper II

Hello, everyone. How are you doing?

My lansweeper's scanning queue is getting stuck randomly. Sometimes it tries to scan offline assets :


In the case of the picture above, the 'processing' asset is an offline asset, and i have to wait the triggering of scan timeout to proceed the other desktops's scan. Sometimes, my queue stuck on 0 assets processing and more than 2000 'In queue'.

Those are my settings about Threads:


I have to restart the server a lot of times every single day to recover the scan. Sometimes even with the service restart the scan queue doesn't works properly. 

Sometimes the queue stucks when i deploy some packages too, but not everytime. It is random.

I tried to repair WMI on some assets that were taking much time to scan but it didn't solve my problem.

My server is configured to not scan Event Viewer Logs too:



I already tried to clean the database and rebuild its indexes as described on one of your articles. I can not think about any solution anymore. I don't know if there are logs about the scan errors, if so, i have no problem to collect it and send to you.

Could you help me?


Engaged Sweeper II

Hi, Obi. How is everything going?

Our System Drivers scan are already disabled:


I'm starting to getting sad 😞

Is there any other possible solution?

Hello there!

If you're still seeing the scanning queue getting stuck, try disabling the below features, clearing the scanning queue, and restarting the Lansweeper Server service on your scanning server.

  • Performance scanning: Disable all performance scanning targets under Scanning\Performance Scanning.
  • Asset radar: Set asset radar to disabled under Scanning\Compatibility & Settings.





Performance scanning was already disabled, we tried to disable Asset Radar, restart the service and try again, but the queue still stuck...




Hello there!

One or more Windows assets with a corrupt WMI repository can also be a possible root cause for the Windows scanning queue to become stuck. As a test, rebuild the WMI repository on those assets, as detailed here:

Lansweeper Tech Support
Lansweeper Tech Support

Hello there!

It is unusual to see offline assets stuck in the scanning queue as offline assets should be skipped immediately if they are not responding when starting the scan.

This might be a long shot, but Windows driver scanning was introduced recently and can cause some scanning delays. As a test, we would recommend disabling driver scanning from the Scanning/Scanned Item Interval page:

  • Uncheck the checkbox in front of SYSTEMDRIVERS, like below: