cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ERROR: The object invoked has disconnected from its clients

sebouh
Engaged Sweeper
Sometime in the last 2 to 3 weeks we started getting period instances of the message "The object invoked has disconnected from its clients" being displayed by IIS when connecting to our Lansweeper web site or while using the site or clicking on a report to view it. It doesn't matter which report it is or which report page (i.e., number of reports or number of results in the query doesn't matter), but it displays this error. If you simply refresh, the page comes up. Anyone have any suggestions on what might be causing this? I don't recall any changes to this server except perhaps some Windows Updates.

I also want to add that I found the following in the Application event log:

Event Type: Warning
Event Source: ASP.NET 2.0.50727.0
Event Category: Web Event
Event ID: 1309
Date: 12/9/2011
Time: 3:53:48 PM
User: N/A
Computer: LANSWEEPERSVR
Description:
Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 12/9/2011 3:53:48 PM
Event time (UTC): 12/9/2011 8:53:48 PM
Event ID: 6ca02f108bb640b2a5427b682c2df99d
Event sequence: 10
Event occurrence: 1
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/Root-1-129679368075575798
Trust level: Full
Application Virtual Path: /
Application Path: C:\Program Files (x86)\Lansweeper\website\
Machine name: LANSWEEPERSVR

Process information:
Process ID: 135996
Process name: w3wp.exe
Account name: MYDOMAIN\s.LS

Exception information:
Exception type: COMException
Exception message: The object invoked has disconnected from its clients. (Exception from HRESULT: 0x80010108 (RPC_E_DISCONNECTED))

Request information:
Request URL:
Request path:
User host address:
User:
Is authenticated: False
Authentication Type:
Thread account name: MYDOMAIN\s.LS

Thread information:
Thread ID: 1
Thread account name: MYDOMAIN\s.LS
Is impersonating: False
Stack trace: at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at System.Web.Hosting.ISAPIWorkerRequestInProcForIIS6.GetBasicServerVariables()
at System.Web.Hosting.ISAPIWorkerRequestInProcForIIS6.ReadRequestBasics()
at System.Web.Hosting.ISAPIWorkerRequest.Initialize()
at System.Web.Hosting.ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

Thanks
Sebouh
3 REPLIES 3

Lansweeper
Lansweeper Former Employee
Lansweeper Former Employee
Enabling logging in SQL Server may help you narrow down the problem.

sebouh
Engaged Sweeper
Yes, database and website are separate. It's been like this since we originally installed Lansweeper. I'm not sure what has changed that is causing this. Any suggestions on where to monitor/log?

Sebouh

Lansweeper
Lansweeper Former Employee
Lansweeper Former Employee
Are your Lansweeper database and website installed on two different servers? It appears that, when the website tries to establish a connection to the database, the connection is temporarily dropped.