→ Having trouble accessing our new support portal or creating a ticket? Please notify our team here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Daniel_B
Lansweeper Alumni

This package will update/install Java on network computers. You need to download the offline installer from the Java website.
The last step disables auto-updates of Java.

1. Open the Java manual download page and download the Offline installers for Windows (32-bit and 64-bit). Copy these into your Package share under folder "\Installers\Java Runtime Environment 8".

2. Review the package (do use the correct folder and installer file names in the "Check installer file" and "Install" steps)

9 REPLIES 9
JWSilver
Engaged Sweeper
Thank you d0dman. I was having the following error for the 32 bit : Result: Deployment ended: The system cannot find the path specified. Even though it was the same path as the 64bit version. I changed it to "Scanning Credentials" and it worked.
DanielB
Engaged Sweeper
thx... woked for me too...
d0dman
Engaged Sweeper
DanielB,

We were able to fix our issue by switching the Run Mode from "System Account" to "Scanning Credentials".

Hope this helps.
DanielB
Engaged Sweeper
I have the same problem with the 32bit version.
The 64bit version works without problems.

doesn't work: "{PackageShare}\Installers\Java\jre-8u66-windows-i586.exe" /s /lang=1031
works: "{PackageShare}\Installers\Java\jre-8u66-windows-x64.exe" /s /lang=1031

And also if I run the 32bit command in cmd it works properly.
d0dman
Engaged Sweeper
I'm having an issue with getting this package to install.

Any time I put in parameters without quotes I receive the following:

Result: Deployment ended: The system cannot find the path specified. Stop(Failure). Credential: (######). ShareCredential: (######).
Command: "\\servername\DefaultPackageShare$\Installers\JavaRE\jre-8u66-windows-i586.exe" /s /lang=1033

However any time I use quotes it opens the install executable (I see it in task manager) and it sits until I kill it (LanSweeper reports a timeout). It seems like it's not recognizing the /s and waiting for a prompt.

Whenever I run the command either way from a command prompt it installs properly.

Thanks for any help!
HammettMike
Engaged Sweeper III
In the LocalLow folder, the files are now under Oracle instead of Sun.
PeterJG
Champion Sweeper II
Thanks.. I've added extra step to run the file from http://www.lansweeper.com/Forum/yaf_postst10942_Script---Remove-Old-Java-Versions-Silently.aspx to remove old versions.
Daniel_B
Lansweeper Alumni
A condition step which looks for the Uninstall registry key of the version to be installed can do this. I modified the package and posted the updated version here.
spallison
Engaged Sweeper III

a check for if certain version of Java is installed, if not install it, would be nice!

also, it seems to be uninstalling the software on one PC I have, have you come across this before? but it is installed OK

Thanks for the Package

New to Lansweeper?

Try Lansweeper For Free

Experience Lansweeper with your own data.
Sign up now for a 14-day free trial.

Try Now