Showing results for 
Show  only  | Search instead for 
Did you mean: 
Engaged Sweeper III
I hope someone would have insight for this one ...

I've been running Lansweeper on a VM, ESXi 4.1, Windows 2008 R2 64 bit. About three weeks ago I've updated to version 4.2 ( and all of a sudden some strange things started happening; extremely high disk I/O's, the VM would reset itself (almost like someone pulled the power cord on a physical machine), applications won't launch, and the machine would impact production.
I figured maybe putting Lansweeper on a VM is not a best practice (albeit the ESXi server is very fast and has plenty of resources, other VM's such as Exchange servers, Terminal server, etc. is running just fine) so I decided to move it to a dedicated physical machine.
The new machine has a quad core CPU, 4 GB RAM, SAS drives, running win 7 Pro 64 bit.

That workstation is performing flawlessly, up to the point when I start the Lansweeper service (I've set it to manual startup), when I start up the service, all hell breaks loose with amazingly the same symptoms - high I/O's, no other applications would launch (notepad, services.msc, etc.) and shortly thereafter the workstation would reset its own power, just like the VM did.
Coincidence?? Highly unlikely, but I'm lost .. The Application event log shows only one error enty right after I start the service:
Event ID 1000, Source - Application Error

Faulting application name: svchost.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1
Faulting module name: ntdll.dll, version: 6.1.7601.17514, time stamp: 0x4ce7c8f9
Exception code: 0xc0000005
Fault offset: 0x000000000002baad
Faulting process id: 0x2e8
Faulting application start time: 0x01cc9815c2e24175
Faulting application path: C:\Windows\system32\svchost.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll

Following that I get event ID 1001 (Windows Error Reporting)
I then stop the Lansweeper service, and the next entry in the Application event log is event ID 17147, source - MSSQL$SQLEXPRESS and the description is:
"SQL Server is terminating because of a system shutdown. This is an informational message only. No user action is required."

I went back to my VM and saw the same entries in the event log there.
I'm sorry for saying it like this, but... WTF???
Hemoco, help please! We need Lansweeper up and running!
Champion Sweeper
The hotfix worked for me also. No more Fault offset: 0x000000000002baad errors in the Application log or freezes and reboots since installing it on 11/8.
Champion Sweeper
Our server appears to have started this randomly about 1PM yesterday. I was trying to rescan some machines to see if MapPoint had uninstalled remotley and it all went bad. We had to disable the lansweeper service to get the server to boot into Windows because the RPC services were hung "Stopping". If the server sat in that state long enough it would reboot itself and there was about a 50/50 chance it would come up OK.

I filtered the Application log and see there have beem some random Exception code: 0xc0000005 Fault offset: 0x000000000002baad errors since the server went live but yesterday there was close to a dozen. I installed the patch and started the service manually and will keep an eye on it.

A side note to this is we keep our database on a seperate server so considering there is very little data on the scan server is there a guide somewhere on how to connect to an existing database in the even the scan server ever had to be reloaded?
Lansweeper Alumni
Technut27 wrote:
A side note to this is we keep our database on a seperate server so considering there is very little data on the scan server is there a guide somewhere on how to connect to an existing database in the even the scan server ever had to be reloaded?

If there is ever a need to reinstall the Lansweeper service or move it to another machine altogether, the steps are the following:

- Stop the service on the old machine (in case of a move).
- (Re)install the Lansweeper service on the new machine by running the Lansweeper setup again, choosing New Installation\Advanced Install and selecting only the service for installation.
- Stop the service on the new machine.
- In your Lansweeper configuration files make sure that the Data Source, User ID and Password correspond with your SQL Server settings. The config files are:
%Program Files%\Lansweeper\Service\Lansweeperservice.exe.config
%Program Files%\Lansweeper\Website\web.config
- If the name of the scanning server has changed, execute the below script in your Lansweeper configuration console under Lansweeper\Database Scripts. Replace “newserver” with the new name of your scanning server.
update tsysasservers set servername='newserver'

- Restart the service.
Engaged Sweeper III
The hotfix worked like a charm; thank you for the quick response!!
Lansweeper Alumni
Please make sure service pack 1 for windows 2008 R2 is installed.

Apply patch: on the scanning server.