Showing results for 
Show  only  | Search instead for 
Did you mean: 
Champion Sweeper
Hi guys,

We have disabled the Microsoft Store in our whole domain.
Now I have received a request to install the Translator app from microsoft, which is only available in the store.
I checked the internet if it's possible to download some kind of installer for apps to deploy them to "offline"-clients , or in our case: clients who don't have access to the store. To my surprise it's actually possible (I didn't expect microsoft to think of this, I haven't seen much offline-friendlyness since w10 came out).

It's possible to download the AppxBundle and install it via powershell.

So I downloaded it and if I run the command below manually on a client, it works perfect.
add-appxpackage \\Server\PackageShare$\lovely.AppxBundle

Next I tried to create a package with either the command (powershell.exe -command "add-appxpackage \\Server\PackageShare$\lovely.AppxBundle") or the ps1. It looked fine at first, the package returned success at the end.
But when I went to check, the app was not installed.
I've tried different variations using commands or external scripts. The deplyoments always end successfully but just doesn't seem do anything on the client.

Did anyone else already try to install store apps this way?
I know there's google translator aso. online but the users asked for this specific app. My hands are bound, if it's possible to deploy it I have to do it (if someone can confirm that it's not possible I'm perfectly happy with that too).
Honored Sweeper
And can you call it via admin command prompt to see if it works normally and installs.
Champion Sweeper II
Can you test out a simple PowerShell based script to verify it is the specific action you are performing and not something to do with Powershell in general? I just verified that this works in my environment:

powershell.exe -command out-file C:\Windows\Temp\hello.txt
Champion Sweeper
Hmm, now there's something I probably should have tested earlier:
Is it possible, that apps cannot be installed for all users at once (or ist there a special command to do that)?
If I login with a local admin and use the "currently logged in" run mode it seems to work

Did this work as expected? I'm looking to do the same thing for the dang Quick Assist app.