Showing results for 
Show  only  | Search instead for 
Did you mean: 
Engaged Sweeper

I discovered several issues today that I cannot explain and are quite annoying. 

1. Servers previously discovered are all the sudden not found anymore. After manually adding the server back in Lansweeper the new item is deleted and the "old" server with all its history data appears again.
2. Servers appear offline while in fact are online (red dot instead of green dot). Pinging the server from the Lansweeper server confirms that a connection can be established and the server can be scanned (firewall is off on NIC).
3. IP addresses change to random other IP addresses. Till now I found a couple of the above mentioned vanished servers that when shown again have an IP address that never has been assigned to the server. DNS entries for these servers have the correct IP address.

We are now using version but this was also in the previous version. I upgraded to see if these problems would be solved just to find the previously added servers to be vanished again.

I also would like to know if the detection and registration of multiple IP addresses per NIC will be added in the future? We also have several servers with multiple nics with different ranges, I would like to be able to register these also automatically.

Lansweeper Employee
Lansweeper Employee

Are you scanning both your production environment and staging? Meaning, is there a cloned system in staging that looks identical to your production? Without more information, it appears there's a duplicate and Lansweeper is getting confused which server is which IP. 

Tim N.
Lansweeper Employee

Hi Tim,

This is one of the VMs showing this behaviour. It is a clone but has it own settings, IP , MAC address etc. We see this also with a couple of VMs that have been cloned as they had to be exact copies (that are in production). It seems with one of the last releases the detection of machines has changed. This was never an issue in the years we use Lansweeper. Problem is that it is making the software unusable. As for now I have about 4-5 VMs I cannot see in Lansweeper. Therefor also the network list, the list of IP addresses, software installs etc is incomplete.

Engaged Sweeper

We still see this issues.

Here is an example. This server when I run a nslookup from the lansweeper server I get:

However in Lansweeper the IP address is linked to a server which is a copy of the original server that is used for our staging environment. 
It also is shown in the server overview


The same happens to other Windows servers that are copies of each other.