→ Having trouble accessing our new support portal or creating a ticket? Please notify our team here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
julianbr
Engaged Sweeper
Hi!

I have a problem with the "Active Directory: Enabled/disabled computers" report.

I have activated to scan disabled computers in AD, and I can find them if I search for them in Lansweeper.

However, the reports only show computers enabled in AD (no computers in that list are listed as "FALSE")



I really need some help here. Don't know why this is happening.

This is the report that I'm using.

Select Top 1000000 Coalesce(os.Image, at.AssetTypeIcon10) As Icon,
a.AssetID,
a.AssetName,
Case
When Coalesce(adc.IsEnabled, 0) = 0 Then 'False'
Else 'True'
End As EnabledInAD,
at.AssetTypename As Type,
a.Domain,
a.Username,
a.Userdomain,
a.IPAddress,
a.Description,
ac.Manufacturer,
ac.Model,
Case (a.Assettype)
When -1 Then os.OSname
When 11 Then ls.OSRelease
When 13 Then mi.SystemVersion
Else ''''
End As OS,
a.SP As SP,
ac.Location,
tsysIPLocations.IPLocation,
a.Firstseen,
a.Lastseen
From tblAssets a
Inner Join tblADComputers adc On a.AssetID = adc.AssetID
Inner Join tblAssetCustom ac On a.AssetID = ac.AssetID
Inner Join tsysAssetTypes at On at.AssetType = a.Assettype
Inner Join tblState s On s.State = ac.State
Left Join tsysOS os On a.OScode = os.OScode
Left Join tblLinuxSystem ls On ls.AssetID = a.AssetID
Left Join tblMacOSInfo mi On mi.AssetID = a.AssetID
Left Outer Join tsysIPLocations On a.LocationID = tsysIPLocations.LocationID
Where s.Statename = 'Active'
Order By adc.IsEnabled Desc,
a.Assettype,
a.AssetName
1 REPLY 1
Andy_Sismey
Champion Sweeper III
Hi,

Its not because you are looking for ACTIVE devices -Where s.Statename = 'Active' , if the disabled assets are mark as "NON-Active" they wont appear on the report, depends on how you have your server configured ?

A

New to Lansweeper?

Try Lansweeper For Free

Experience Lansweeper with your own data.
Sign up now for a 14-day free trial.

Try Now