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Symptoms

After restarting or updating Lansweeper, we get the First Run wizard again.

Diagnosis

The LocalDB database runs under its own service, Lansweeper LocalDB Service. When the Lansweeper LocalDB service is started, the lansweeperdb.mdf file is being attached to the SQL LocalDB instance. This .mdf file must be located in the Program Files (x86)\Lansweeper\SQLData folder on the Lansweeper server.

If customers get a new install aka first run wizard with an empty database each time they restart or update, likely the correct .mdf file was not stored in the correct location.

If the .mdf file is not located in the SQLData folder, the Lansweeper LocalDB will revert to an empty .mdf file after a service restart, which will result in the first run wizard being presented after which it will start with a new, empty database.

Solution

The lansweeperdb.mdf file must be located in the Program Files (x86)\Lansweeper\SQLData folder on the Lansweeper server.

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