→ Celebrate SysAdmin Day 2024 with Lansweeper Enter our Giveaway here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
vargaboti
Engaged Sweeper II
Hi
We made upgrade today from 3.5 Premium to ver.4 Premium. The setup has finished without error. But accessing the web UI or Administrative UI we get the following error: ” Conversion failed when converting the varchar value 'SERVERNAME' to data type int.”
We would appreciate urgent help.
I will add here the errors :
WebUI-error
System.Data.SqlClient.SqlException: Conversion failed when converting the varchar value '4710S' to data type int.
at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
at System.Data.SqlClient.SqlDataReader.HasMoreRows()
at System.Data.SqlClient.SqlDataReader.ReadInternal(Boolean setTimeout)
at System.Data.SqlClient.SqlDataReader.Read()
at System.Data.Common.DataAdapter.FillLoadDataRowChunk(SchemaMapping mapping, Int32 startRecord, Int32 maxRecords)
at System.Data.Common.DataAdapter.FillFromReader(DataSet dataset, DataTable datatable, String srcTable, DataReaderContainer dataReader, Int32 startRecord, Int32 maxRecords, DataColumn parentChapterColumn, Object parentChapterValue)
at System.Data.Common.DataAdapter.Fill(DataSet dataSet, String srcTable, IDataReader dataReader, Int32 startRecord, Int32 maxRecords)
at System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior)
at System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior)
at System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable)
at DreamweaverCtrls.DataSet.DoInit()

5 REPLIES 5
vargaboti
Engaged Sweeper II
Not related to the opened topic, just wondering,I think it don't needs a new one. It is a way on the forum to change my Rank: Freeware user? As you already know, that I am not. Just Browsing topics I see that is not related to post counts.
Hemoco
Lansweeper Alumni
vargaboti wrote:
Not related to the opened topic, just wondering,I think it don't needs a new one. It is a way on the forum to change my Rank: Freeware user? As you already know, that I am not. Just Browsing topics I see that is not related to post counts.

On the main forum page there is a link at the bottom "upgrade your status to premium user"
Hemoco
Lansweeper Alumni
Please send us the complete error message by e-mail at lansweeper@hemoco.com
vargaboti
Engaged Sweeper II
Could not upload any image.
Minor changes in the log because confidentiality.
2010-04-20 10:58:53.856 Log opened. (Time zone: UTC+03:00)
2010-04-20 10:58:53.856 Setup version: Inno Setup version 5.3.6 (a)
2010-04-20 10:58:53.856 Original Setup EXE: C:\Documents and Settings\Administrator\Desktop\4.0_setup.exe
2010-04-20 10:58:53.856 Setup command line: /SL5="$401A2,8710592,64512,C:\Documents and Settings\Administrator\Desktop\4.0_setup.exe"
2010-04-20 10:58:53.856 Windows version: 5.02.3790 SP2 (NT platform: Yes)
2010-04-20 10:58:53.856 64-bit Windows: No
2010-04-20 10:58:53.856 Processor architecture: x86
2010-04-20 10:58:53.856 User privileges: Administrative
2010-04-20 10:58:53.887 64-bit install mode: No
2010-04-20 10:58:53.887 Created temporary directory: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\2\is-KSB3G.tmp
2010-04-20 10:58:55.278 OS: osWin2003Srv
2010-04-20 10:58:55.340 Previous Data:
2010-04-20 10:58:55.340 DboInstalled: yes
2010-04-20 10:58:55.340 SvcInstalled: yes
2010-04-20 10:58:55.340 WebInstalled: yes
2010-04-20 10:58:55.340 InstConnectionString: Provider=SQLOLEDB.1;Password='*********';Persist Security Info=True;User ID=sa;Data Source='SERVERNAME'
2010-04-20 10:58:55.340 WebInstMode:
2010-04-20 10:58:55.340 StopWWW80: no
2010-04-20 10:58:55.340 iisWebSiteID:
2010-04-20 10:58:55.340 iisWebSite:
2010-04-20 10:58:55.340 iisVDir:
2010-04-20 10:58:55.340 iisPort:
2010-04-20 10:58:55.340 lswSvcPort: 9524
2010-04-20 10:58:55.340 New installation detected:
2010-04-20 10:58:55.340 Installation Path: C:\Program Files\lansweeper
2010-04-20 10:58:55.340 Installed version: 3.5.2 Currently installing: 4.0
2010-04-20 10:58:55.356 Service version: 3.5.2.4 Currently installing: 4.0.0.18 Upgrade required: yes
2010-04-20 10:58:55.356 Service UserName: 'MyDomain'\administrator
2010-04-20 10:58:55.356 Website version: 0 Currently installing: 4001 Upgrade required: yes
2010-04-20 10:58:56.668 Database version: 0 Currently installing: 2 Upgrade required: yes
2010-04-20 10:58:56.949 Exists HKLM\software\Microsoft\INetStp @ProductString
2010-04-20 10:58:57.434 ------------ Lansweeper Setup Started ------------
2010-04-20 10:58:57.434 OS: Microsoft Windows Server 2003Version 5.2 (Build 3790: Service Pack 2)
2010-04-20 10:58:57.434 Inst: 4.0.24
2010-04-20 10:58:57.449 Member of domain: Yes
2010-04-20 10:58:57.449 Fully Qualified Domain Name (FQDN): Mydomain.net
2010-04-20 10:58:57.449 NetBios Domain Name: 'MyDomain'
2010-04-20 10:59:56.027 Checking connection to 'SERVERNAME' ...
2010-04-20 10:59:56.543 Connection to 'SERVERNAME' ... succeeded!
2010-04-20 10:59:58.058 Checking rights for user: sa ...
2010-04-20 10:59:58.074 Checking rights for user: sa ... succeeded!
2010-04-20 10:59:58.574 Checking if Lansweeper Database exists ...
2010-04-20 11:00:28.793 Checking user account needed for service setup ..
2010-04-20 11:00:29.043 Result returned by function: 0
2010-04-20 11:00:29.043 UserName / Password are OK!
*****Swaped text,succeded steps,becouse post limit******
2010-04-20 11:01:12.886 ------------ Running Post-Upgrade tasks ------------
2010-04-20 11:01:12.902 ------------ Installing Lansweeper Database ------------
2010-04-20 11:01:12.902 Upgrading Lansweeper Database to SchemaVersion 1...
2010-04-20 11:26:04.798 Upgrading Lansweeper Database upgradescript0.sql done.
2010-04-20 11:26:04.798 Upgrading Lansweeper Database to SchemaVersion 2...
2010-04-20 11:26:06.017 Upgrading Lansweeper Database upgradescript1.sql done.
2010-04-20 11:26:06.017 Upgrading Lansweeper service configuration file ...
2010-04-20 11:26:06.033 Configuring Lansweeper service ...
2010-04-20 11:26:06.080 Updating table "tsysASServers" done.
2010-04-20 11:26:06.111 Error: Updating table "tsysASDomains" or "tsysASServers"; Query: INSERT INTO [tsysASDomains] ([Servername],[DomainName],[Netbiosname]) VALUES('MyServer','Mydomain.net',''MyDomain'')UPDATE [tsysASServers] SET [activescanning]=1 WHERE [ServerName]='MyServer'Violation of PRIMARY KEY constraint 'PK_tsysASDomains'. Cannot insert duplicate key in object 'dbo.tsysASDomains'
2010-04-20 11:26:06.111 Configuring active scanning feature ...
2010-04-20 11:26:06.127 Updating table "tsysIPScanRanges" done.
2010-04-20 11:26:06.127 Starting Lansweeper service ...
2010-04-20 11:26:09.470 Lansweeper service started successfully.
2010-04-20 11:26:09.580 Starting Lansweeper Build-In Web Server service ...
2010-04-20 11:26:09.580 Error starting Lansweeper Build-In Web Server service: The operation completed successfully
2010-04-20 11:26:09.580 Sharing Actions folder...
2010-04-20 11:26:09.939 Updating table "TSysConfig" result; Query: IF (SELECT COUNT(*) FROM [TSysConfig]) >= 1 UPDATE [TSysConfig] SET [Config]='LSW', [ActionPath]='\\MT'MyDomain'\lansweeper$' ELSE INSERT INTO [TSysConfig] ([Config], [ActionPath]) VALUES ('LSW', '\\MT'MyDomain'\lansweeper$')OK.
2010-04-20 11:26:09.939 Need to restart Windows? No
2010-04-20 11:26:36.939 ------------ Lansweeper Setup Finished ------------
Hemoco
Lansweeper Alumni
Please post your install.log file and a screenshot of the error.
Set debug to "true" in your web.config file to get a detailed error.