Showing results for 
Show  only  | Search instead for 
Did you mean: 
Champion Sweeper
Upgraded to the latest version of Lansweeper and now new reports i've created don't display properly, if I click on this report I just created I get the following error message.

Report has an invalid syntax:
The object 'dbo.web40repNoSoftwareUnilauncher' does not exist in database 'lansweeperdb' or is invalid for this operation.

This is the query and it works fine through the builder

Select Top 1000000 tblcomputers.Computername, tblcomputers.ComputerUnique, tblcomputers.Username, tblComputersystem.Manufacturer, tblComputersystem.Model, tblcomputers.LastknownIP, tblcomputers.Lastseen From tblcomputers Inner Join tblComputersystem On tblcomputers.Computername = tblComputersystem.Computername Inner Join tblOperatingsystem On tblcomputers.Computername = tblOperatingsystem.Computername Where tblcomputers.Computername Not In (Select tblsoftware.ComputerName From tblsoftware Where tblsoftware.softwareName = 'unilauncher') Order By tblcomputers.ComputerUnique

I created a duplicate report of another query and this new gives the same error message as above, but the existing report works fine.
Champion Sweeper
Latest version of Lansweeper has solved this for me. I just have to resave the reports.
Lansweeper Alumni
Can you please contact us by e-mail for this problem (