→ Celebrate SysAdmin Day 2024 with Lansweeper Enter our Giveaway here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
BendItLikeBedna
Engaged Sweeper
We're running Lansweeper Premium 4.0.0.24. We're seeing a number of problems trying to get our Workgroup computers to show up and be inventoried.

We've made the DCOM changes, turned off the firewall, and created appropriate entries in the Lansweeper configuration in the form:

DOMAIN: WORKGROUPNAME

USERNAME: ./username

Password: <password>

When running the test connection, we're able to successfully see the device, but receive: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) when trying to use any alternate credentials (./username, WORKGROUP/username ). Even with the firewall off, we occasionally see the RPC errors, but usually get these credential-based errors with the workgroup computers.

Any advice or ideas for next steps? I'd prefer to avoid joining these to the domain just to get them to show up in the inventory.

Thanks!
3 REPLIES 3
Hemoco
Lansweeper Alumni
Your slashes should be backslashes:
.\administrator instead of ./administrator
Lansweeper wrote:
Your slashes should be backslashes:
.\administrator instead of ./administrator


That stops the RPC error that I was occasionally seeing, but still throws:

DNS test
-----------------------------------------------
Is this the correct remote IP: [correct IP address]
If not, please check for DNS problems

\root\cimv2 Remote WMI access test FAILED
Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Remote WMI test
-----------------------------------------------
\root\cimv2 Remote WMI access test FAILED
Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

Remote Registry test using WMI
-----------------------------------------------
\root\default Remote WMI access test FAILED
Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

---

I'm able to ping these devices and just used the username/password that I provided to remote desktop into the machine, so I know the credentials are legitimate. Any other advice?
Made the below changes to my secpol and everything started working:

1. Start -> Control Panel -> Administrative Tools -> Local Security Policy
2. Navigate to Security\Local Policies\Security Options
a. Network Access: Let everyone permissions apply to anonymous users - Set to Enabled
c. DCOM: Machine Access Restrictions - Add Anonymous, Everyone, Interactive, Network, System with full rights options set.
d. Network Access: Let everyone permissions apply to anonymous users - Set to Enabled
e. Network Access: Sharing security model for local accounts - Set to Classic

I'm thinking 2c or 2e. was the problem, but I'm not sure...

-bb