→ Celebrate SysAdmin Day 2024 with Lansweeper Enter our Giveaway here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rjang
Engaged Sweeper

Hello All,

We recently deployed LsAgent on users' machines.

The first thing we wanted to try with the data is uninstalling undesired programs.

I have tried the deployment package for uninstalling the specific program.

However, the company recently restricted using the Network drive due to security reason.

And we are only seeing failed messages. Is there any other way to uninstall machines without Network drive?

Also, will LsAgent can somehow conduct these kind of function? (Uninstalling programs, changing computer name, ...)

Untitled picture.png

I would be much appreciated for any ideas and knowledge shares!

Thank you!

2 REPLIES 2
rjang
Engaged Sweeper

Dear David,

Thank you for your reply.

I have tried accessing the C drive on the client machine from the server (has administrative access).

However, I could not access to the drive (see attached screenshot).

Wouldn't SMB port be opened to be able to access the network drive?

The company don't allow the SMB port opened for the security matters.

Will there be any other way to access the C drive remotely to use the deployment feature?

Or any other way to uninstall programs?

 

Thank you!

 
 

 

 

David_GF
Lansweeper Tech Support
Lansweeper Tech Support

hi @rjang 

The MSIUninstaller option of the deploymetns module does not require access to a shared drive, as it takes the list of installed software from the software detected in the network. The error in the screenshot refers to access to the C: drive in the local machine. Your scanning credential must have access to administrative share C$ on the target computer, as an executable required for running the deployment is written into a C:\Windows\LSDeployment folder on the computer. The target computer's firewall must be properly configured to allow access to the machine. If you are using Windows Firewall and enabled the remote administration exception for agentless scanning, deployments should ordinarily already be allowed through the firewall. However, in some Windows builds it is necessary to enable and allow the Remote Scheduled Tasks Management rule in Windows Firewall as well.

Could you ensure that the scanning credential you are using for the deployment has access to C$ and that the firewall is properly configured?

 

LsAgent can't perform deployments, they need to be executed from the scan server itself.

 



~~~~~~~ (〃 ̄︶ ̄)人( ̄︶ ̄〃) ~~~~~~~
Sweep that LAN, sweep it!