cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Deployment packages failed after upgrade version9.5.0.4

Boudjema
Engaged Sweeper II
Today we have upgraded our server to the latest version (9.5.0.4).
After that, Lansweeper seems to be fine but we cannot push package anymore. Each time that we try, we have the following message:
“Preliminary checks failed. Task Registering Error. The current version of the native library (1.4) does not support the original or minimum version of the ".NET Framework NGEN v4.0.30319" task (1.6/1.6). This is likely due to attempting to read the remote tasks of a newer version of Windows from a down-level client. Credential: (FFF\administrateur). ShareCredential: (fmsf-MP007\Lansweeper).”

We have tried to install different packages to at least 4 computers without success. We also tried with different agents accounts.

NB: During the upgrade process, we have also installed the latest paches for the windows server.
1 ACCEPTED SOLUTION

Bruce_B
Lansweeper Employee
Lansweeper Employee
Just bumping this topic, a patch was made available today, version 9.5.10.1. Update instructions are unchanged: https://www.lansweeper.com/knowledgebase/updating-your-installation/

View solution in original post

4 REPLIES 4

TassieTrooper
Engaged Sweeper II
Unbelievable!!!! I have had a support ticket from the 5th April, ever since I patched our server, and I have been conversing with LS Support for the last two weeks and I find out that you have released a fix via the forum!!!!!!!!

Average to say the least.

Obi_1_Cinobi
Lansweeper Tech Support
Lansweeper Tech Support
TassieTrooper wrote:
Unbelievable!!!! I have had a support ticket from the 5th April, ever since I patched our server, and I have been conversing with LS Support for the last two weeks and I find out that you have released a fix via the forum!!!!!!!!

Average to say the least.


This particular bug was introduced with Lansweeper version 9.5 which was released on April the 14th, as such, we presume that you might be facing a different issue. If you are still experiencing issues we would recommend reaching out to our support team again.

Bruce_B
Lansweeper Employee
Lansweeper Employee
Just bumping this topic, a patch was made available today, version 9.5.10.1. Update instructions are unchanged: https://www.lansweeper.com/knowledgebase/updating-your-installation/

Bruce_B
Lansweeper Employee
Lansweeper Employee
This is a known issue in version 9.5, related to a new task scheduler cleanup routine. Deployments towards older or newer operating systems than your Lansweeper server may not always be functional. E.g. if your scanning server is running Windows 2012, it isn't able to deploy towards Windows 10 workstations due to this issue.

Please contact the technical support team via support@lansweeper.com to receive a workaround.

This issue will be referred to as LAN-13095 on our changelog when a fix is available.

https://www.lansweeper.com/changelog/