→ Having trouble accessing our new support portal or creating a ticket? Please notify our team here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ithelpdeskutah
Engaged Sweeper II
I have attempted multiple times now to update Lansweeper to no avail. The Lansweeper launches (or seems to) and then simply never opens anything. A service runs for it on task manager however there is no evidence it is actually running.

I really tried everything I could think of to fix this.

Thanks,
Patrick Jackson
6 REPLIES 6
ithelpdeskutah
Engaged Sweeper II
So it was a mix of issues. The Sys Admin was also running a network logging software on the same VM as Lansweeper, so it bogged and froze my updates. But the other issue that we had was for whatever reason we have to run as administrator to force it to go through.
eclark82
Engaged Sweeper
I have found that if I disable and stop the lansweeper service, Restart the server, Set the service back to Automatic, Run the upgrade it finishes in less than 2 minutes and all is good.
AZHockeyNut
Champion Sweeper III
one thought your account that you are running the installer as might not have the necessary db or OS permission. I love the idea to contact support though.... duh. I should have said that! lol
Michael_V
Champion Sweeper III
Please contact us at support@lansweeper.com
While the installer is running a temporary log file is created in the %temp% folder
ithelpdeskutah
Engaged Sweeper II
Sorry about this, really poor post on my part.
Your version Latest version
Service version 6.0.0.51 6.0.0.63
Website version 6051 6063

This is the notice I am getting on Lansweeper. Our database is hosted separate from our lansweeper software. Even running as administrator will not work. It will seem to launch, think about it and fail. If I open task manager it shows multiple instances of the install running but wont actually run the installation. I unfortunately am in charge of Lansweeper but started with the company not too long ago and have limited understanding and access to the backend of the infrastructure. I will attempt to run a few of your suggestions and see what happens.

Thanks
AZHockeyNut
AZHockeyNut
Champion Sweeper III
Might help if you indicate what you tried and what version you had that you were trying to upgrade from.

I have sql server express backend and got a message today that Lansweeper needed updating. downloaded the update and am now running v6063 if that is of use to you.

I am sure you checked that you have access to the database, that it was running, and that you had run the exe as an admin on the iis box?
By chance, anything in the event viewer?

open an administrative command prompt, cd to the folder where you put the download, run lansweepersetup /? and there is a list of command line parameters it supports.
the interesting ones might be to LOG and CLOSEAPPLICATIONS just by chance.