Showing results for 
Show  only  | Search instead for 
Did you mean: 
Engaged Sweeper
I'm trying to make LanSweeper works, but scanning on any comp (excluding my comp where LanSweeper Server is installed where it works) gave back those results:

all our computers are working in one domain which server is not comp with lansweeper serwer
all our computers have domain account which is member of domain administrators and local administrator of each computer
this account is called looper@dom-pl

1. user looper@dom-pl logs in on lansweeper server
service LanSweeper (LSservice.exe) starts as looper@dom-pl
program LSwinap.exe starts as looper@dom-pl too
2. looper@dom-pl logs in on client computer
he starts cmd and there lsclient.exe (which is ip of Lansweeper server)
-- LanSweeper client --
Connecting to success
Sending data....success
3. LanSweeper server (LSwinap.exe) finds user and start to diagnose
- no info else computername of client and error is typed in lansweeper base
- in syslog and in errors table of lansweeper :"RPC Server is not avaible. (HRESULT: 0x800706BA)"
- in syslog I have suuch description: " DCOM was unable to communicate with the computer "Name" using any of the configured protocols"
all firewalls are diseabled
ports 135 and 9542 (LSwinap.exe) are open

i don't know what else I could do, I spend more then 6 hours reading about RPC and trying make it all works... could You help me please?
i readed near all messages on this forum, and anything i found on microsoft.technet pages

Engaged Sweeper
i checked your script between two clients computers with default company settings and it works too.
i shed myself in surmise...
regards 🙂
Engaged Sweeper
i did it both on client and server pc, but it startet to work allover network so i guess it should be done only on server pc
your script works now too for localhost "." and for ipadresses of other computers but i guess it works because of previous setts
thanks for quick response, now i can start using lansweeper
best regards
Engaged Sweeper
ok. I have something...
I run mmc, there choose "add/remove snap-in" then add "component services"
explore tree and choose properities on "my computer"
and there i set:
"default protocols" too TCP/IP with port range "3000-5100" for intranet use
"default properities" turn on both options
"COM security" added looper@dom-pl to every of forth options
and it start to work after service restart...
now I have to check what options should be on (maybe less then i did) and find way to propagate this settings for all company computers...

Lansweeper Alumni
Most likely causes of the problem

1) windows firewall blocks the access on the client pc's
2) WMI is not installed or not running on the client computer (is installed and running by default on win2000/XP)

Let's try running a vbs script from the server with the correct credentials and see if we get wmi results.
First let it run on the client locally.

Save this with notepad as a .vbs file.

strComputer = "." --> means local computer

On Error Resume Next

strComputer = "."
Set objWMIService = GetObject("winmgmts:" _
& "{impersonationLevel=impersonate}!\\" & strComputer & "\root\cimv2")

Set colItems = objWMIService.ExecQuery("Select * from Win32_Processor")

For Each objItem in colItems
Wscript.Echo "Manufacturer: " & objItem.Manufacturer
Wscript.Echo "Maximum Clock Speed: " & objItem.MaxClockSpeed


New to Lansweeper?

Try Lansweeper For Free

Experience Lansweeper with your own data.
Sign up now for a 14-day free trial.

Try Now