Showing results for 
Show  only  | Search instead for 
Did you mean: 
Engaged Sweeper
I have the latest version of Lansweeper installed on one of our servers. We just started trying to use the uninstall feature for programs and have been running into a WMI error. The error states: "Cannot connect to WMI service on". The only way that we can seem to get this to work is if we are logged into the server itself and run it as the domain admin.

I don't know if anyone has tried this or figured out how to get it to work, but I would really appreciate it if someone could help me out.

I have tried a couple of things to get it to work, and one is by putting the runas command in with the code to run the program within the lansweeper settings. I can get it to prompt for a password, but as soon as it is entered, it disappears and nothing else pops up.

We have also tried using the ShellRunAs program from Microsoft, and it again only wants to run as domain admin.

Thank you for any hints or tricks to get this to run as a domain user, or even someone in the domain admin group.

I know it says here that I am a freeware user, but I am a Premium member. I just can't remember my account.
Engaged Sweeper
We figured that one out the hard way. In order to get it to work out to the way we wanted, we changed the script to run shellrunas from microsoft and put that in the actions folder (same folder as the remoteuninst.exe file.

Shellrunas can be found here:

Then we used this script for the uninstall function:

{actionpath}ShellRunas.exe /netonly {actionpath}RemoteUninst.exe {smartname}

This will allow a regular domain user to use lansweeper, but then allow them to uninstall as a domain admin if they put the correct credentials in when prompted.
Lansweeper Alumni
Please note that scanning credentials are NOT used to run custom actions. If an action requires administrative privileges on the target machine, the user initiating the action must have those privileges.
Engaged Sweeper
Thank you for the reply.

I changed the credentials to the domain admin for scanning, yet still receive the same error message. Do I have to wait for it to pass through something before it will work out?
Engaged Sweeper II
The user account you are running the scans with must have rights to WMI or be a local admin of that machine.