Showing results for 
Show  only  | Search instead for 
Did you mean: 
Engaged Sweeper

Hi everoyone,

I did this deployment to uninstall the new version of Java and install Java 202 in our clients.

If i deploy the single steps it works normally, but when I run the whole deployment, it got stuck at the second step.

At first I though the problem could be that there was not timeout between steps,I introduce it but nothing change it.

For the timeout I have tried with >Powershell.exe "start-sleep -s 90" & timeout /nobreak /t

Looking through the logs i got this error:

Result: Package timeout reached. Task Error: The last run of the task was terminated by the user. Timeout: (1200Sec)

I also tried changing the maximun time for the deployment, no changes.

Any ideas??

Thanks to everyone!!

Engaged Sweeper III
Before i stopped using Java entirely i used to use the below script to remove old Java installs and then install the latest using the msi.

taskkill /F /IM iexplorer.exe
taskkill /F /IM iexplore.exe
taskkill /F /IM firefox.exe
taskkill /F /IM chrome.exe
taskkill /F /IM javaw.exe
taskkill /F /IM jqs.exe
taskkill /F /IM jusched.exe

powershell -executionpolicy bypass -noninteractive -noprofile -file .\removejava.ps1

xcopy java.settings.cfg %ProgramData%\Oracle\Java\ /Y

msiexec.exe /i jre1.8.0_281.msi SPONSORS=0 JU=0 JAVAUPDATE=1 AUTOUPDATECHECK=1 RebootYesNo=No WEB_JAVA=1 /q /L*V "c:\windows\temp\javainstall.log"

The removejava powershell script is as below.
It will will uninstall any version of Java.

$javaVer = Get-ChildItem -Path HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall, HKLM:\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall  |
Get-ItemProperty |
Where-Object {$_.URLInfoAbout -match "java" } |
Select-Object -Property DisplayName, UninstallString

ForEach ($ver in $javaVer) {

If ($ver.UninstallString) {

$uninst = $ver.UninstallString
& cmd /c $uninst /quiet /norestart