→ Celebrate SysAdmin Day 2024 with Lansweeper Enter our Giveaway here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kprince
Engaged Sweeper
I have variables for the Lansweeper API (LSAPI) and others that are in (), and if I create without the &CustomFields.... the ticket gets added OK.
But when I use either of the following for the URL, it doesn't work. I get this:
{"Files":null,"Success":false,"Message":"Something went wrong. The creation was unsuccessful -> Please use the correct input format for custom fields."}

?Action=AddTicket&Key=%(LSAPI)&Subject=%(Subject)&Description=%(Description)j&Type= Service Request&Priority=Medium&UserName=%(UserName)&AgentName=%(AgentName)&CustomFields={“customFields”:[{ “name”:”End User”,”value”:”Kate Something” },{“name”:”County Department”,”value”:”Highway”}]})

or

?Action=AddTicket&Key=%(LSAPI)&Subject=%(Subject)&Description=%(Description)j&Type= Service Request&Priority=Medium&UserName=%(UserName)&AgentName=%(AgentName)
&CustomFields=%7B%0A%20%20%20%20%22customFields%22%3A%20%5B%0A%20%20%20%20%20%20%20%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%22name%22%3A%20%22End%20User%22%2C%0A%20%20%20%20%20%20%20%20%20%20%20%20%22value%22%3A%20%22Kate%20Something%22%0A%20%20%20%20%20%20%20%20%7D%2C%0A%20%20%20%20%20%20%20%20%7B%0A%20%20%20%20%20%20%20%20%20%20%20%20%22name%22%3A%20%22County%20Department%22%2C%0A%20%20%20%20%20%20%20%20%20%20%20%20%22value%22%3A%20%22Highway%22%0A%20%20%20%20%20%20%20%20%7D%0A%20%20%20%20%5D%0A%7D)

Has anyone had success in adding a ticket with custom fields this way?
1 REPLY 1
kprince
Engaged Sweeper
I found a way around this. I AddTicket without the Custom Fields, then I EditTicketCustomField, but I have to Edit each custom field separately.

?Action=EditTicketCustomField&Key=%(LSAPI)&TicketID=%(PatternMatchingTicketID_TicketID)&CustomFieldName=County%20Department&CustomFieldValue=%(County Department)

This works, but like I said, I have to edit every custom field with a separate web request/call