→ Having trouble accessing our new support portal or creating a ticket? Please notify our team here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mcoleman
Engaged Sweeper II
Hi,
Has anyone else noticed that the Export to CSV option now produces a semicolon delimited file, rather than a colon delimited file? Also Export to Excel produces weird cell formatting as well as skipping some data.

Thanks,
Mark
1 ACCEPTED SOLUTION
Karel_DS
Champion Sweeper III
Just some info.

The way a CSV file is formatted can be changed to other characters under Control Panel -> Region and Language -> Additional Settings... -> List separator. The separator cannot be a comma if for instance the decimal symbol is already a comma. However this doesn't always immediately seem to work.

As a workaround you could save a file in Excel format, open it in Microsoft Excel (or Open Office), then save it as a CSV file.

View solution in original post

6 REPLIES 6
crashff
Champion Sweeper
I'm using 5.3.34, and following the instructions Karen posted does NOT work. I have checked the settings on both my server and my workstation - the List separator is set to comma, but the CSV file I am getting is using semicolons.

CSV is "comma separated value". This should -never- depend on a regional setting. It is a set file standard.
Karel_DS
Champion Sweeper III
Just some info.

The way a CSV file is formatted can be changed to other characters under Control Panel -> Region and Language -> Additional Settings... -> List separator. The separator cannot be a comma if for instance the decimal symbol is already a comma. However this doesn't always immediately seem to work.

As a workaround you could save a file in Excel format, open it in Microsoft Excel (or Open Office), then save it as a CSV file.
Karel DS wrote:
Just some info.

The way a CSV file is formatted can be changed to other characters under Control Panel -> Region and Language -> Additional Settings... -> List separator. The separator cannot be a comma if for instance the decimal symbol is already a comma. However this doesn't always immediately seem to work.

As a workaround you could save a file in Excel format, open it in Microsoft Excel (or Open Office), then save it as a CSV file.


Anyone know of this has been "fixed" in LANsweeper yet? This thread mentions it is a bug.
Daniel_B
Lansweeper Alumni
We could not reproduce the issue. As we didn't hear back from you, we assume that it was related to Excel and already resolved.
mcoleman
Engaged Sweeper II
Hey Daniel,
Actually the export to Excel wasn't skipping data, it was formatting these extremely large cells down towards the bottom of each page which made the rest of the sheet appear blank. The rest of the data was there if you went down past the large empty cells.
I will send in a copy of an excel file with a link to this thread.

Thanks,
Mark
Daniel_B
Lansweeper Alumni
The CSV export with semicolon was confirmed as a bug. Regarding the Excel export, we could not reproduce any issue. Which data is being skipped in your case? If possible, could you send an example (report screenshot and XLS export) to support@lansweeper.com. Please send the link to this forum topic as well.