cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MartinMeduna
Lansweeper Employee
Lansweeper Employee

We recently published an integration application for Jira Assets
Lansweeper App for Jira Service Management Assets 
We have found an issue, we have identified the root cause, we are currently working on a fix, and we will publish the new version of the application in  Atlassian store as soon as possible.
Please note that not all customers are effected by this issue, if your integration run fails, you will see in the error in the log:
“Error occurred in get assets resolver. Reason:  The maximum payload size is 200KB.”
Thanks for your patience as we resolve this.

13 REPLIES 13
MartinMeduna
Lansweeper Employee
Lansweeper Employee

Hi jutley,

Unfortunately I do not have any expected date.. we are still working on a fix. 

jutley
Engaged Sweeper III

Great, we can't wait for the update!

We saw that the app tries to fetch 200 assets at a time and the payloads were too big. We were able to get it to start syncing by deleting all of the editable fields the Jira app settings, but we really want those extra fields. Hopefully there can be a setting to say how many assets it fetches at a time when doing the syncing. The more fields you add to the fields list, you may  have to reduce the number of assets it fetches at a time. It would also be helpful if we could choose to only sync assets that were in the "Active" state. 

MartinMeduna
Lansweeper Employee
Lansweeper Employee

We are looking at several options how to implement it. We will try to be smart 😁. And good point about the active state. We can consider it in next version but I cannot commit anything.

eliw
Engaged Sweeper

Can confirm we are seeing this behavior as well. The Assets schema in JSM is populated but no assets sync. Thank you for the update Martin!