Showing results for 
Show  only  | Search instead for 
Did you mean: 
Engaged Sweeper III
I've been trying for some time an eXtreme switch as SNMP asset with in Lansweeper record.
Unfortunately without success.

The Device Tester works very well and I get the following result:

Lansweeper DeviceTester
Scanning Lansweeper Service (on this machine)..
Status: Service not found
Version: Executable not found
Scanning TCP ports..
Open ports:
22 (SSH)
Closed ports:
21 (FTP)
23 (Telnet)
25 (SMTP)
80 (HTTP)
135 (EPMAP)
139 (NetBIOS Session Service)
443 (HTTPS)
445 (SMB)
9100 (Jetdirect)
16992 (Vpro HTTP)
16993 (Vpro HTTPS)
Scanning SSH..
Error: Timeout exceeded while waiting for welcome message. Make sure you are connecting to an SSH or SFTP server.

Scanning SNMP..
Hostname: Access-IT
Description: ExtremeXOS (Stack) version by release-manager on Thu Sep 21 12:06:37 EDT 2017
Uptime: 289d 19h 24m 49s 0ms
Contact: -----
Location: -----
IpForwarding: 2
Interfaces: 94


But if I enter this information in the credentials and also map the device directly, I get no information about the device, not even an error message.

Even deleting the device and re-searching and capturing did not help.

Do you still have an idea?

Thank you...
best regards
Engaged Sweeper
what is/was the solution for that Problem?
Engaged Sweeper III

problem solved
EDV_OHZ wrote:

problem solved

Hallo EDV-OHZ, wir haben dasselbe Problem bei uns... wie konntest Du das Problem bei Dir lösen?
Lansweeper Employee
Lansweeper Employee
SNMPv3 is supported.

The reason why Hendrik mentioned to running the device tester on the server Lansweeper is installed on is because the tool connects from the machine you run it on to the target. Just because your computer can connect to the switch doesn't mean the server Lansweeper is on can.

It is also best if you scan the switch with an IP range scanning target that does not have SSH scanning enabled (there is a checkbox to disable SSH scanning). You won't need it for the switch and it can cause issues in some situations.

Don't forget that you can also send an email to support for further help if you're stuck. They can send you debug options to take a look at exactly what Lansweeper does during the scan.
Champion Sweeper III
SNMP V3 should work. Please have a look at this article which gives you a few hints:

Otherwise, I'd suggest contacting, they answer quite fast 😉
Engaged Sweeper III

In search of the error, I noticed the following:

An HP switch will be recognized without problems, with all the information I need (snmp v2)
is it possible that Lansweeper does not really support SNMP v3 yet?
Honored Sweeper
Suggest Looking At This To Say Its A Switch.
Engaged Sweeper III
CyberCitizen wrote:
Suggest Looking At This To Say Its A Switch.

Yes, I try it. I changed the asset type to switch, Linux and Network Device. The result is everytime the same.

Although I get access as a Linux Asset with SSH, the queries are of course wrong, as it is a switch OS and not Linux.

SSH server: SSH-2.0-OpenSSH_6.5
System info: %% Unrecognized command: "uname -a"
Hostname: %% Unrecognized command: "uname -n"
Kernel name: %% Unrecognized command: "uname -s"
Kernel release: %% Unrecognized command: "uname -r"
Kernel version: %% Unrecognized command: "uname -v"
Processors: %% Unrecognized command: "cat /proc/cpuinfo 2> /dev/null | grep 'model name' | cut -f2 -d:"
VMware product name: %% Unrecognized command: "esxcfg-info --hardware -F xml 2> /dev/null | grep product-name"
VMware vendor name: %% Unrecognized command: "esxcfg-info --hardware -F xml 2> /dev/null | grep vendor-name"
Disks: %% Unrecognized command: "df -h"
Network: %% Unrecognized command: "/sbin/ifconfig -a

Engaged Sweeper III
Hey Hendrik,

thank you for the information. Although I do not understand the difference of which device I ask, because the answering device and not the questioning device has the information.

--> I have now started the same test from the server and come to the same result.

Important to know, the device can only communicate SNMP v3.