→ Having trouble accessing our new support portal or creating a ticket? Please notify our team here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Alan_Bentley
Engaged Sweeper
Hi all, New to LanSweeper.


I've created a Asset Identification Report, and would like to include BIOS age of computers to the report.

If I add/link tblBIOS to the report, the report now only shows PC (or assets that have a BIOS).

Is there a way to add the table, so that its not compulsory, and only show tblBIOS.ReleaseDate if it exists?

Thanks in Advance
1 ACCEPTED SOLUTION
RCorbeil
Honored Sweeper II
More than likely you're INNER JOINing the table to your report; that's the default for the LANSweeper report editor. Change that to a LEFT JOIN.

W3Schools.com on SQL joins

Simplified version:
INNER JOIN: show me only records that have an entry in the joined table.
LEFT JOIN: show me all records. If there's entry in the joined table, show me that, too.

View solution in original post

2 REPLIES 2
Alan_Bentley
Engaged Sweeper
Thanks you

That fixed my issue.

As you can guess, I only have very little db experience.
RCorbeil
Honored Sweeper II
More than likely you're INNER JOINing the table to your report; that's the default for the LANSweeper report editor. Change that to a LEFT JOIN.

W3Schools.com on SQL joins

Simplified version:
INNER JOIN: show me only records that have an entry in the joined table.
LEFT JOIN: show me all records. If there's entry in the joined table, show me that, too.