→ Celebrate SysAdmin Day 2024 with Lansweeper Enter our Giveaway here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
robert_beissner
Engaged Sweeper
I tried to upgrade from 3.52 to 4.0 and failed this same way. So I completely removed Lansweeper and the MSSQL and tried a fresh install, and got the same errors in the installation error log.

Error: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied

3 REPLIES 3
Hemoco
Lansweeper Alumni
Can you run setup again and try to connect to sql server BEISSNER-DT\SQLLANSWEEPER2K8
robert_beissner
Engaged Sweeper
Here's the problem:
2010-05-10 16:51:57.393 ------------ Running Prerequisites tasks ------------
2010-05-10 16:51:57.398 Installing Microsoft SQL 2008 Express Edition ...
2010-05-10 16:55:35.716 Installing Microsoft SQL 2008 Express Edition ... done.
2010-05-10 16:55:35.716 Checking DB Connection (after downloaded install) ...
2010-05-10 16:55:53.030 Connection to BEISSNER-DT\SQLLANSWEEPER2K8 ... failed!; Connection string: Provider=SQLOLEDB.1;Password=mysecretpassword0*;Persist Security Info=True;User ID=sa;Data Source=BEISSNER-DT\SQLLANSWEEPER2K8
2010-05-10 16:55:53.030 ------------ Running Preinstall tasks ------------
2010-05-10 16:55:53.033 Removing older Lansweeper services, if exists...
2010-05-10 16:55:53.036 Removing Lansweeper database, if exists...
2010-05-10 16:56:09.777 Error: Dropping Lansweeper Database [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied

complete install.log attached
Hemoco
Lansweeper Alumni
Could you please upload your install.log file.