→ Celebrate SysAdmin Day 2024 with Lansweeper Enter our Giveaway here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jmarmo
Engaged Sweeper III
Since upgrading to the beta Wake On LAN is no longer working. Any suggestions?
12 REPLIES 12
jmarmo
Engaged Sweeper III
Can you add a variable for Subnet Mask, like {Mask}? It would definitely be a useful variable for more than just this issue.
Hemoco
Lansweeper Alumni
jmarmo wrote:
Can you add a variable for Subnet Mask, like {Mask}? It would definitely be a useful variable for more than just this issue.

If you use poweroff.exe you don't need to specify the subnetmask.
Hemoco
Lansweeper Alumni
There is no existing variable for subnetmask.

How Lansweeper wake on lan works:
If you have the enterprise version, the WOL command is sent from scan server (the one that scanned the asset)

There are 2 WOL methods tried by the service:
1)Normal wol.exe method which only works in the local subnet
2)“Poweroff.exe” method which works across subnets, see http://users.telenet.be/jbosman/poweroff/poweroff.htm
jmarmo
Engaged Sweeper III
I'm trying wolcmd. Is {mask} the environment variable for Subnet mask? I can't seem to find the environment variable list in the manual.
Hemoco
Lansweeper Alumni
Most likely you are referring to poweroff.exe?

The same technique is used by the lansweeper service.
If you can wake up a different subnet with poweroff.exe it should also work from the lansweeper service.

This link might also help: http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a008084b55c.shtml
jmarmo
Engaged Sweeper III
Doesn't WOL.exe only work within the subnet you are running it from? I found another utility but can't find the Lansweeper variable for MAC address. I tried {mac} but that didn't seem to work.
jmarmo
Engaged Sweeper III
Doesn't WOL.exe only work within the subnet you are running it from?
Hemoco
Lansweeper Alumni
As a workaround you can use a custom action that runs wol.exe with {mac} parameter
jmarmo
Engaged Sweeper III
In our case the server can't be in the same subnet as our 20 locations. Why the change? It worked flawlessly before. Is there a workaround or a way to change a config file to revert back to the previous method. This is terrible for larger environments with many subnets. If this change was made to be able to multi WOL, I am willing to give that up if I can change it.