→ Celebrate SysAdmin Day 2024 with Lansweeper Enter our Giveaway here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dledger
Engaged Sweeper III
We are just starting to explore our trial of the Helpdesk and have run into a curiosity. We use Skype for Business as our Corporate phone system. It is set up to send us a transcribed email when someone leaves us a voicemail. I set up our "Helpdesk" user with a phone number and license so a user can call Helpdesk, leave a voicemail, and the voicemail triggers an email to our Helpdesk email address. This successfully opens a ticket. It is outstanding! BUT, when a user calls from a cell phone or non company phone and leaves a voicemail the transcribed email goes right to the Helpdesk_ignore mailbox. A ticket never gets created.

Would anyone know why a voicemail from a company phone creates a ticket but a voicemail from an outside caller does not? Any suggestions on how to fix this?
1 ACCEPTED SOLUTION
dledger
Engaged Sweeper III
Scottydogg wrote:
dledger wrote:
Scottydogg wrote:
Is there a rule set up in the email account?


The only Rule in the Email is the one I just created to forward all the tickets that come in with Voice Mail in the subject to forward to me. Then I created a rule in my email to forward those emails back to helpdesk. That changes the "FROM" to me instead of the phone number. Then Lansweeper opens the ticket just fine.

I did open a ticket with Lansweeper and they are working with us to debug the program.


Have you had any issues with replies to the ticket causing any bounce back emails? I have our voicemail emailing ithelpdesk directly. Tickets are created no problem. The problem arises when the ticket is closed. It wants to send a "closed" reply to the sender, which is a voicemail account with no email account tied to it. I have created a new service account for the voicemail that will forward all messages to ithelpdesk, but I'm concerned about the closing emails being sent back to that account and forwarded to ithelpdesk again and a new ticket being created. Basically a helpdesk ticket storm.


Not with the Voicemail system. FYI, Lansweeeper support analyzed our logs and determined that the Lansweeper software is not letting the emails through if it does not have a "valid" email address in the FROM:. They are going to add "FROM: phone numbers" as a future feature request.

View solution in original post

11 REPLIES 11
Scottydogg
Engaged Sweeper
Is there a rule set up in the email account?
dledger
Engaged Sweeper III
Scottydogg wrote:
Is there a rule set up in the email account?


The only Rule in the Email is the one I just created to forward all the tickets that come in with Voice Mail in the subject to forward to me. Then I created a rule in my email to forward those emails back to helpdesk. That changes the "FROM" to me instead of the phone number. Then Lansweeper opens the ticket just fine.

I did open a ticket with Lansweeper and they are working with us to debug the program.
dledger wrote:
Scottydogg wrote:
Is there a rule set up in the email account?


The only Rule in the Email is the one I just created to forward all the tickets that come in with Voice Mail in the subject to forward to me. Then I created a rule in my email to forward those emails back to helpdesk. That changes the "FROM" to me instead of the phone number. Then Lansweeper opens the ticket just fine.

I did open a ticket with Lansweeper and they are working with us to debug the program.


Have you had any issues with replies to the ticket causing any bounce back emails? I have our voicemail emailing ithelpdesk directly. Tickets are created no problem. The problem arises when the ticket is closed. It wants to send a "closed" reply to the sender, which is a voicemail account with no email account tied to it. I have created a new service account for the voicemail that will forward all messages to ithelpdesk, but I'm concerned about the closing emails being sent back to that account and forwarded to ithelpdesk again and a new ticket being created. Basically a helpdesk ticket storm.
dledger
Engaged Sweeper III
Scottydogg wrote:
dledger wrote:
Scottydogg wrote:
Is there a rule set up in the email account?


The only Rule in the Email is the one I just created to forward all the tickets that come in with Voice Mail in the subject to forward to me. Then I created a rule in my email to forward those emails back to helpdesk. That changes the "FROM" to me instead of the phone number. Then Lansweeper opens the ticket just fine.

I did open a ticket with Lansweeper and they are working with us to debug the program.


Have you had any issues with replies to the ticket causing any bounce back emails? I have our voicemail emailing ithelpdesk directly. Tickets are created no problem. The problem arises when the ticket is closed. It wants to send a "closed" reply to the sender, which is a voicemail account with no email account tied to it. I have created a new service account for the voicemail that will forward all messages to ithelpdesk, but I'm concerned about the closing emails being sent back to that account and forwarded to ithelpdesk again and a new ticket being created. Basically a helpdesk ticket storm.


Not with the Voicemail system. FYI, Lansweeeper support analyzed our logs and determined that the Lansweeper software is not letting the emails through if it does not have a "valid" email address in the FROM:. They are going to add "FROM: phone numbers" as a future feature request.
Scottydogg
Engaged Sweeper
That was going to be the backup plan. We solved it by allowing by unblocking the domain of the emails, sent by the voicemail server (Toshiba BTW), on the IT Helpdesk Outlook account. Considering how unstable Outlook rules can be at times, I just might go ahead and set up that other email account. Just to be sure.
Esben_D
Lansweeper Employee
Lansweeper Employee
So there is no actual email address linked to the sender of the email?

If the sender is just a number, and there is no email address, than I could see that causing the issue. What you could always to is setup an auto-forward on a second email address, and just forward all the emails from the second email address to the helpdesk one.
dledger
Engaged Sweeper III
Charles.X wrote:
So there is no actual email address linked to the sender of the email?

If the sender is just a number, and there is no email address, than I could see that causing the issue. What you could always to is setup an auto-forward on a second email address, and just forward all the emails from the second email address to the helpdesk one.


I am going to try that. I am setting up a rule in the ITHelpdesk email box to forward emails where the sender is a phone number to my email. Then I will set a rule up in mine to bounce it right back. (That does work if I do it manually)
Scottydogg
Engaged Sweeper
I was having similar issues with voicemail ticket creation. I found that the IT helpdesk account we were using for ticket creation was blocking the domain of our voicemail server ans was shunting off the voicemail emails to the Junk folder. I had to set the IT helpdesk Junk folder to allow those messages. Couldn't do it by sender, as each Voicemail email address contains a different prefix depending on their phone extension.
dledger
Engaged Sweeper III
I have determined that the email generated from our voicemail system has the callers phone number listed as the FROM:.

FROM: +16165551111
SENT: Wednesday 2/28/2018
TO: ITHelpdesk
SUBJECT: Voice Mail (8 seconds)

Lansweeper is automatically moving these emails to the helpdesk_ignore. If I take that same email and change the FROM by forwarding it to myself and then sending it back to helpdesk it creates the ticket fine. Something is triggering Lansweeper to automatically ignore email that has a phone number as FROM: I checked all of the ignore rules and we have nothing enabled. No ignore rules at all. Any idea's