→ Having trouble accessing our new support portal or creating a ticket? Please notify our team here

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dteague
Engaged Sweeper III
After seeing someone wanting the weather, I already was using a RSS feed from a difference source for weather, but forgot I could have an iframe to do it. When I set it up as http://forecast.io/embed/#lat=39.3256&lon=-85.4796&name=Greensburg&color=#00aaff&font=Georgia as the URL, it displays, but then under it, I get a message that The Contend cannot be displayed in a frame.

Ideas to why?
11 REPLIES 11
KadeBarton
Engaged Sweeper
I was able to get this fixed by just going in and typing editing the custom widget's .aspx file to show the following:

Background: none;


I however am brand new to LanSweeper and am wondering where in the .aspx I can make the URL go to forcast.io's information and have it be a regular widget as opposed to having to input the URL for each user who wants that custom widget.

Sorry to bring up an old post, but this one seems to be pretty helpful.
LJayP
Engaged Sweeper III
Thanks for sharing this, was trying to get the error message to hide. Very useful thanks
JTempleton
Engaged Sweeper III
Thanks! That is very helpful!
JTempleton
Engaged Sweeper III
Sorry to bring up an old post, but what did you do to remove the error graphic? I tried to follow the link and figure it out, but I couldn't get it to work.
dteague
Engaged Sweeper III
JTempleton wrote:
Sorry to bring up an old post, but what did you do to remove the error graphic? I tried to follow the link and figure it out, but I couldn't get it to work.


Copy Iframe.* from Widgets to Widgetscustom naming them Iframe1.*

in Iframe1.aspx, at line 28, remove background-image: url("<%=ResolveUrl("~/")%>images/iframeErr.png");

Jono
Champion Sweeper II
That's a great idea! Thanks!
Hemoco
Lansweeper Alumni
Check this post: http://www.lansweeper.com/forum/yaf_postsm34739_Widget-to-display-a-picture-from-a-URL.aspx#post34739
dteague
Engaged Sweeper III
Lansweeper wrote:
Check this post: http://www.lansweeper.com/forum/yaf_postsm34739_Widget-to-display-a-picture-from-a-URL.aspx#post34739

Well, I just made a copy of the iframe widget and removed the error graphic reference since everything was there.

Thanks
Hemoco
Lansweeper Alumni
dteague wrote:

Well, I just made a copy of the iframe widget and removed the error graphic reference since everything was there.

That's even better!