→ Having trouble accessing our new support portal or creating a ticket? Please notify our team here

Showing results for 
Show  only  | Search instead for 
Did you mean: 
Engaged Sweeper


I have a Windows 7 machine on my network, but it is not part of my domain.

LanSweeper can find it but cannot scan it, error "Scanning Access Denied".

I have checked the user and password that LSweeper is trying to use when scanning this asset and they are set perfectly.

I have installed LSagent on the target Asset and also run the WMI script too.

When I use the test connection tool, it fails if I try to scan it using the computer name, but works perfectly if I use the IP address (I assume this is because it is not in the domain, so DNS does not resolve the name).

Checked the Firewall on the W7 machine as well.

Extra: I have more W7 machines in my Inventory and are scanning without problems and all I had to do was use the wmi script or install LSagent.

What else should I try?


(Attachments: ls1.png is when I run the connection test tool by scanning the computer's name and ls2.png is when I run it by scanning its IP address).

Best regards, Chris.
Lansweeper Tech Support
Lansweeper Tech Support



Check if the Win7 machine has received and installed all the latest updates.


LsAgent should work. Remote into the client machine and see if you can set up a connection to your scan server on port 9524/TCP